В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alekseyovsyann
alekseyovsyann
13.08.2022 09:20 •  Информатика

Напишите программу на паскале ! ученики 4 класса вели дневники наблюдения за погодой в апреле и ежедневно записывали дневную температуру. данные заносили в массив размерностью 30. данные в диапазоне от -10 до 10 градусов. 1. найдите среднюю температуру для дней, когда столбик термометра поднимался выше нуля градусов. 2. определите количество таких дней. если их нет, то выведите no. 3. определите день с самой низкой температурой, выведите в формате < > дня < > .

Ответ:
MariyaPak2701
MariyaPak2701
06.10.2020 05:02
Если то вот так:
begin
  Writeln('Температура апреля:');
  var a:=ArrRandom(30,-10,10); a.Println;
  var sr:=a.Where(x->x>=0).Average;
  Writeln('Средняя температура для дней, когда >0 = ',sr:4:1);
  var k:=a.Where(x->x>=0).Count;
  if k=0 then writeln('No')
  else Writeln('Количество дней с температурой >0 = ',k);
  Writeln('Самая низкая температура: ',a.IndexMin+1,' день апреля');
end.

Пример:
Температура апреля:
-3 -5 9 7 0 -7 -3 8 -5 9 -5 1 -8 3 0 3 -2 -7 9 4 2 -4 -10 7 1 7 4 3 6 -2
Средняя температура для дней, когда >0 =  4.6
Количество дней с температурой >0 = 18
Самая низкая температура: 23 день апреля
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?