В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alii333
alii333
19.02.2021 19:50 •  Информатика

Дано n чисел. найти сумму четных чисел. паскаль. через mod

Ответ:
rendly21
rendly21
09.10.2020 06:14
Program chet;
uses crt;
var N, a, b, c:Integer;
begin
a:=0;
Write('Сколько чисел будем вводить? ');
ReadLn(N);
for b:=1 to n do
begin
Write('Введите число номер ', b, ': ');
Readln(c);
if c mod 2 = 0 then
begin write(' - это чётное число, берём его!');
a:=a+c;
WriteLn('Текущая сумма равна ', a);
end
end;
Writeln('');
Write('Итоговая сумма чётных чисел: ', a);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?