В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Dasha9716
Dasha9716
02.01.2021 18:35 •  Информатика

Pascal после очередного этапа чемпионата мира по кольцевым автогонкам на автомобилях с открытыми колесами формула-а гонщики собрались вместе в кафе, чтобы обсудить полученные результаты. они вспомнили, что в молодости соревновались не на больших болидах, а на картах – спортивных автомобилях меньших размеров.
друзья решили выяснить победителя в одной из гонок на картах. победителем гонки являлся тот гонщик, у которого суммарное время прохождения всех кругов трассы было минимальным.
поскольку окончательные результаты не сохранились, то каждый из n участников той гонки вспомнил и выписал результаты прохождения каждого из m кругов трассы. к сожалению, гонщикам было сложно вычислить победителя той гонки. в связи с этим они попросили сделать это вас.
требуется написать программу, которая вычислит победителя гонки на картах, о которой говорили гонщики.
формат входных данных
первая строка входных данных содержит два целых числа n и m (1 ≤ n, m ≤ 100). последующие 2∙n строк описывают прохождение трассы каждым из участников. описание прохождения трассы участником состоит из двух строк. первая строка содержит имя участника с использованием только латинских букв (строчных и заглавных). имена всех участников различны, строчные и заглавные буквы в именах различаются.
вторая строка содержит m положительных целых чисел, где каждое число – это время прохождения данным участником каждого из m кругов трассы (каждое из этих чисел не превосходит 1000). длина каждой строки не превышает 255 символов.
формат выходных данных
в выходные данные необходимо вывести имя победителя гонки на картах. если победителей несколько, требуется вывести имя любого из них.
пример входных и выходных данных

входные данные
выходные данные
5 3
sumaher
2 1 1
barikelo
2 1 2
olonso
1 2 1
vasya
1 1 1
fedya
1 1 1
fedya

Ответ:
alexeypimkin
alexeypimkin
10.10.2020 13:23

begin

 var (n, m) := ReadlnInteger2;

 var (sm, tm):= ('', integer.MaxValue);

 for var i := 1 to n do

 begin

   var s := ReadlnString;

   var t := ReadSeqInteger(m).Sum;

   ReadlnString;

   if t < tm then

     (sm, tm) := (s, t)

 end;

 Write(sm)

end.

Замечание. Строки могут содержать любые символы., а не только латинские буквы.


Pascal после очередного этапа чемпионата мира по кольцевым автогонкам на автомобилях с открытыми кол
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?