В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Five11111
Five11111
09.09.2021 01:18 •  Информатика

Составить программу вычисления суммы всех натуральных чисел, меньших м, в записи которых нет парных цифр. использовать функцию определения количества парных цифр в числе. язык c++

Ответ:
arinkaapelsink
arinkaapelsink
09.10.2020 06:05

#include <iostream>

using namespace std;

int sum( int n  ){

   int k = 0;

   int t = n;

   while ( t > 0 )

   {

       if ( ( t % 10 ) % 2 == 0 )

           k++;

       t /= 10;

   }

   return k;

}

int main()

{

   int  M,S,p;

   cin  >> M;

   S = 0;

   for ( int i = 1; i < M; i++ ){

    p = sum(i);

       if ( p == 0 ) {

           S = S + i;

       }

   }

   cout << S;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?