Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Selektro
07.04.2020 07:48 •
Информатика
Написати программу в c++ builder для обчислення середнього арифметичного 5 чисел, що вводяться з клавіатури.
Ответ:
карина1958
08.10.2020 23:47
//Язык C++
#include <iostream>
int main()
{
const int size = 5;
int numbers[size];
int sum = 0;
for (int i = 0; i < size; i++)
{
std::cout << "Enter " << i + 1 << " number: ";
std::cin >> numbers[i];
sum += numbers[i];
}
std::cout << "\nArifmetical mean: " << (double)sum / size;
return 0;
}
//Example: 1 2 3 4 5 => output: 3
0,0
(0 оценок)
Популярные вопросы: Информатика
mikiliki889
05.04.2022 21:49
Подалуйста! нужно написать алгоритм следующих 2 на языке паскаля 1. даны два действительных положительных числа. найдите среднее арифметическое, суму, разность и произведение...
t22422
05.04.2022 21:49
Нужно, ! задан массив х[1..n].какое условие надо поставить вместо многоточия, чтобы найти произведение отрицательных элементов массива переменной p? p: =0; for k: =1 to n...
Elizabetsimmer
14.09.2022 13:34
Впиши в фигуры номера слов. 1 рябина,2 вишня,3 яблоня,4 сад,5 весна, 6 капель, 7 вода, 8 верба....
Cанек3017
14.09.2022 13:34
Дан массив, содержащий n элементов и заполненный случайными числами от -10 до 9. сформировать новый массив из значений элементов, стоящих на четных местах. подсчитать количество...
tatyanamost
06.06.2022 11:46
I. рассмотрите пример и укажите вид информации.виды информациипример6.07.1923353,6123рисунок карабликустановите соответствие....
Ks1mak
11.02.2021 06:36
№10. сколько бит содержит сообщение, содержащее 0.25 кбайт? ...
ададсжсжэвжю
03.08.2022 18:26
За. рассмотрите пример и укажите вид информации.виды информациипримердитина: eet—таген11детенцететепениетінеедета наредна наградана лечениена,е-тренка-- азетіт .ts eetrahnilна...
playerkeks
05.09.2020 17:25
Программа, составленная по приведённому алгоритму, обрабатывает целое положительное число X. Сколько существует таких чисел X, обрабатывая которые программа последовательно...
FoxyDi
23.02.2022 11:40
Как можно использовать заметки к слайдам?...
Leonova23
20.09.2020 12:53
Перо Чертёжника находится в точке (x,y). Сместиться на вектор (a,b), если a=2,b=6. После выполнения команды, координаты новой точки: (x+ , + )....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <iostream>
int main()
{
const int size = 5;
int numbers[size];
int sum = 0;
for (int i = 0; i < size; i++)
{
std::cout << "Enter " << i + 1 << " number: ";
std::cin >> numbers[i];
sum += numbers[i];
}
std::cout << "\nArifmetical mean: " << (double)sum / size;
return 0;
}
//Example: 1 2 3 4 5 => output: 3