В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
про783
про783
03.08.2020 07:49 •  Информатика

Напишите программу, которая подсчитывает, сколько различных чисел содержится в данном списке. входные данные программа получает на вход несколько чисел (не более 1000), записанных в одной строке через пробел. все числа по модулю не превосходят . выходные данные программа должна вывести единственное число - количество различных чисел среди данных. пример ввод вывод 2 5 1 3 1 5 (python)

Ответ:
гегпнгеггне
гегпнгеггне
08.10.2020 21:52

Например, можно действовать так: сначала отсортировать массив, а затем пройти по нему, подсчитывая количество элементов, которые не совпадают со следующим за ним элементом.

a = list(map(int, input().split()))

count = 1

a.sort()

for i in range(len(a) - 1):

    if a[i] != a[i + 1]:

        count += 1

print(count)

Но проще всего преобразовать массив в множество (set):

a = set(map(int, input().split()))

print(len(a))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?