В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
annymayy0
annymayy0
24.11.2021 18:47 •  Информатика

Спо информатике "составьте программу, по которой компьютер десять раз запросит ввод любых чисел и в результате даст произведение этих чисел (используя два вида циклов)" *на паскале*

Ответ:
ocreater
ocreater
27.08.2020 07:26
В Паскале имеется три вида стандартных циклов:
1) цикл с параметром (цикл for ... to ... do ...)
2) цикл с предусловием (цикл while ... do ...)
3) цикл с постусловием (цикл repeat ... until ...)
Программа с использованием цикла с параметром:
program z1;
var i:integer;
    x,p:real;
begin
p:=1;   {задаем начальное значение произведения}
for i:=1 to 10 do  {указываем количество повторений}
begin
   readln(x);         {вводим очередное число х}
   p:=p*x;             {умножаем введенное число х к произведению р}
end;
writeln(p);            {вывод результата}
end. 

Программа с использованием цикла с предусловием:
program z1;
var i:integer;
    x,p:real;
begin
p:=1;     {задаем начальное значение произведения}
i:=1;      {задаем начальное значение счетчика}
while i<=10 do     {задаем условие повторения цикла: пока i<=10}
begin
   readln(x);       {вводим очередное число х}
   p:=p*x;           {умножаем введенное число х к произведению р}
   i:=i+1;             {увеличиваем счетчик i на единицу}
end;
writeln(p);         {вывод результата}
end.

Программа с использованием цикла с постусловием:
program z1;
var i:integer;
    x,p:real;
begin
p:=1;     {задаем начальное значение произведения}
i:=1;      {задаем начальное значение счетчика}
repeat           {повторять все указанные действия}
   readln(x);   {вводим очередное число х}
   p:=p*x;       {умножаем введенное число х к произведению р}
   i:=i+1;         {увеличиваем счетчик i на единицу}
until i>10;      {до тех пор, пока счетчик i не станет больше 10}
writeln(p);      {вывод результата}
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?