В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
23774947hhbhut
23774947hhbhut
24.09.2021 23:38 •  Информатика

Составьте программу подсчета числа элемента одновременного массива, превосходящих среднее арифметическое элементов данного массива.

Ответ:
лилу110
лилу110
08.10.2020 17:45
Программа написана на PascalABC.NET

// Ниже код:

program element;
var a: array[1..1000] of real;    i, j, c: integer;    b: real;    begin  writeln('Введите число элементов: ');  read(j);    for i:= 1 to j do    begin      read(a[i]);      b:= b + a[i];    end;    b:= b / j;    for i:= 1 to j do    if a[i] > b then inc(c);    writeln;  write('ответ: ', c);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?