В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
aaysu228
aaysu228
26.12.2020 16:54 •  Информатика

Составить программу для нахождения количества и суммы всех чисел, оканчивающихся на 4 на промежутке от 1 до 100. в паскале. подробно , чтобы было понятно.

Ответ:
vikaclevervikap01a7w
vikaclevervikap01a7w
08.10.2020 17:12
Program aaa;
var
   i,z,sum:integer;
begin
   sum:=0; //сумма чисел
   z:=0; //счётчик
   for i:=1 to 100 do
      if(i mod 10 = 4) then begin //проверка последней цифры, если 4,то прибавляем к счётчику единицу и к сумме число
         z:=z+1;
         sum:=sum+i;
      end;
   writeln(z,' ',sum); //Выводим ответ
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?