В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
victoriareih
victoriareih
19.09.2022 17:39 •  Информатика

Напишите программу к вообще не понимаю! заранее ! поставлю ответ лучшим! шоколадка стоит a рублей с копеек. какое наибольшее количество шоколадок можно купить за b рублей?

Ответ:
zaya46
zaya46
09.08.2020 23:59
Program program1;
var
a, b, c, n: integer;
begin
writeln('Введите стоимость шоколадки:');
write('рублей и копеек через пробел: ');
readln(a, c);
write('Введите количество рублей, которые имеются у Вас: ');
readln(b);
if (a < 0) or (c < 0) or (c > 99) then
writeln('введите корректные данные')
else
begin
n := trunc(b / (a + c/100));
writeln(n, ' шоколадок');
end;
end.
0,0(0 оценок)
Ответ:
Настя9474
Настя9474
09.08.2020 23:59
Var
  a,b,c:integer;
begin
  Write('Сколько стоит шоколадка (руб коп)? ');
  Read(a,c);
  Write('Сколько у вас рублей? ');
  Read(b);
  Write('Вы можете купить шоколадок: ',
    (100*b) div (100*a+c))
end.

Пример
Сколько стоит шоколадка (руб коп)? 35 50
Сколько у вас рублей? 140
Вы можете купить шоколадок: 3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?