В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Panovamasha33
Panovamasha33
25.05.2021 17:41 •  Информатика

Напишите программу, реализующую игру на угадывание целого числа от 1 до 10. угадываемое число определяется случайно, пользователь вводит предполагаемое значение. если число угадано, программа выводит набранные очки, а если нет-предлагает повторить попытку. каждая безуспешная попытка снижает . в начале игры назначается 10 . , , составить сдать надо завтра.

Ответ:
Anna2271
Anna2271
27.08.2020 06:23
Var a,b,k,i:integer;
begin
b:=random(10)+1;
k:=10;
WriteLn('Привет, я задумал число от 1 до 10. Угадай его.');
while a<>b do
begin
Write('Введи число: ');
ReadLn(a);
if a<>b then
begin
WriteLn('Не угадал... Попробуй повторить попытку.');
k:=k-1
end
end;
WriteLn('Молодец! Угадал! Набранные очки: ',k)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?