Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
FiveKh
16.11.2021 04:59 •
Информатика
Дан массив b(m), m≤15 . все элементы с четными номерами удвоить, а с нечетными - заменить нулями. вывести на печать исходный и переформированный массив. на языке с++
Ответ:
9573st
08.10.2020 12:02
#include <iostream>
using namespace std;
int main() {
int m;
cout << "m = ", cin >> m, cout << "\n";
int b[m];
srand(time(NULL));
cout<<"array:\n";
for (int i=0; i<m; i++)
{
b[i]=rand() % 50;
cout<<b[i]<<" ";
}
cout << "\n";
for (int i=0; i<m; i++)
if ((i+1)%2==0) b[i] *= 2;
else b[i]=0;
for (int i=0; i<m; i++) cout << b[i] << " ";
cout << "\n";
return 0;
}
Пример:
m = 10
array:
47 3 29 46 36 31 2 2 20 20
0 6 0 92 0 62 0 4 0 40
0,0
(0 оценок)
Популярные вопросы: Информатика
hjhjhjhhhhhhh
22.01.2021 18:45
А=1; в=0; с=1; 1) а и в или с 2) не а или в и с 3) а и не в или с 4) (а или не в) и с 5) не (а и в) или с...
Фомида
29.01.2020 00:04
1. какое максимальное количество страниц текста, содержащего 90 символов в строке и по 70 строк на странице, можно сохранить на диске объемом 8,5 гбайт? 2. какой объём...
zeinalovazahra
29.01.2020 00:04
1. 50 петабайт (пбайт) = тбайт = байт 2. сколько байт в словосочетании теория кодирования? 3. объем информационного сообщения 11 348 456 байт выразите в гбайтах....
Olga692010
29.01.2020 00:04
Свопросом поколение процессоров intel 9 букв...
ulyana783
29.01.2020 00:04
Валфавите формального (искусственного) языка имеется всего два знака – крестик и нолик . каждое слово этого языка состоит ровно из пяти знаков. какое максимальное число...
Котя5461
21.04.2022 04:46
1.составить программу, которая вводит с клавиатура массив из 5 целых чисел и выводит на экран значение четвертого элемента массива . 2.дан массив из 10 элементов, заполненный...
ленок352
23.07.2021 22:04
Значение каких величин должен сообщить водителю на бензоколонке что бы заправить машину...
KeselMeme
23.07.2021 22:04
Склавиатуры вводится число, если число принадлежит промежутку от 10 до 30, то его умножают на три, иначе умножают на -1, результат вывести на экран...
ТвойЩенок
25.01.2022 11:26
Язык. вставьте пропущенные буквы, раскройте скобки. подчеркните грамматические основы. выделите союзы, определите вид придаточных предложений. 1. широко что есть писатели...
kredy44belkabelka44
25.01.2022 11:26
Вравносторонний трапеции, периметр которой 62 см, диагональ является биссектрисой острого угла. найдите площадь трапеции, если ее высота = 12см...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
using namespace std;
int main() {
int m;
cout << "m = ", cin >> m, cout << "\n";
int b[m];
srand(time(NULL));
cout<<"array:\n";
for (int i=0; i<m; i++)
{
b[i]=rand() % 50;
cout<<b[i]<<" ";
}
cout << "\n";
for (int i=0; i<m; i++)
if ((i+1)%2==0) b[i] *= 2;
else b[i]=0;
for (int i=0; i<m; i++) cout << b[i] << " ";
cout << "\n";
return 0;
}
Пример:
m = 10
array:
47 3 29 46 36 31 2 2 20 20
0 6 0 92 0 62 0 4 0 40