В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ева2208
Ева2208
30.03.2020 00:53 •  Информатика

3.составить программу, которая устанавливала бы, является ли четырёхугольник со сторонами a, b, c, d параллелограммом. нужно

Ответ:
ivasil2012
ivasil2012
08.10.2020 11:31
Pascal :
Код чтобы скопировать : http://rextester.com/EFBKO81416

3.составить программу, которая устанавливала бы, является ли четырёхугольник со сторонами a, b, c, d
0,0(0 оценок)
Ответ:
anna228po
anna228po
08.10.2020 11:31
Язык C++.
#include < iostream >
using namespace std;
int main(){
int a, b, c, d, u;
cout << "Все четыре угла прямые (Да - 1/Нет - 0)?" << endl;
cin >> u;
switch(u){
case 0:{
cout << "Введите длины сторон: " << endl;
cin >> a >> b >> c >> d;
if((a==c && d == b) && (a==b && c==d)&&(a==d && b==c) &&(c==b && a == d))
cout << "Не параллелограмм";
else if((a==c && d == b) || (a==b && c==d)||(a==d && b==c) || (c==b && a == d))
cout << "Параллелограмм";
else
cout << "Не параллелограмм";
break;
}
case 1:{
cout << "Не параллелограмм";
}
}
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?