В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
РусикЛох
РусикЛох
30.11.2022 11:15 •  Информатика

Написать программу на pascal для определения в двумерном массиве вещественных чисел d [7, 7] суммы всех элементов на главной диагонали.

Ответ:
vladpin01
vladpin01
02.10.2020 04:37
VAR   D : array [1..7,1..7] of real; s: real; i,j: Byte;
begin
s:=0;
FOR i:=1 TO 7 DO
FOR j:=1 TO 7 DO D[ i,j]:= RANDOM(10);
FOR i:=1 TO 7 DO
begin
FOR j:=1 TO 7 DO
WRITE ( D[ i,j]);WRITEln();
end;
FOR i:=1 TO 7 DO
FOR j:=1 TO 7 DO if i=j then s:=s+D[i,j];
WRITEln('s=',s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?