Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Beario
30.01.2023 19:28 •
Информатика
Вариант 4 дан массив из n чисел (xi). найти максимальный элемент массива (max).
Ответ:
Neznayka66
08.10.2020 09:57
Const
MAX_SIZE = 200;
var
N, Max, i: integer;
X: array [1..MAX_SIZE] of integer;
begin
randomize;
write('N = ');
readln(N);
writeln('Исходный массив: ');
for i := 1 to N do
begin
X[i] := random(101)-50;
write(X[i], ' ');
end;
writeln;
Max := X[1];
for i := 1 to N do
if (X[i] > Max) then
Max := X[i];
writeln('Максимальный элемент массива = ', Max);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Serpopi
28.07.2021 10:52
Дан фрагмент программы. после выполнения фрагмента программы определите значение х. a : = 16 b : = 4 b : = a - 2 * b если a b то x : = a - b/4 иначе x : = b/14 - a...
08.01.2023 00:24
1. при обращении к ячейке электронной таблицы 1) имя строки и имя столбца никак не указывается 2) указывается имя строки и имя столбца произвольным образом 3) вначале...
red011
08.01.2023 00:24
Заверши ряд чисел, вписав недостающее седьмое число. в ответе запиши сумму всех семи чисел. 1 1 2 6 24 120...
artemnikishovartemka
02.05.2022 05:56
72 перевести в 2 ссч 102 перевести в 2ссч 151 перевести в 2 ссч 249 перевести в 8 ссч 249 перевести в 16 ссч (не циферки а перешение с делением)...
WOWCAT291981
27.06.2022 12:44
Укажите, какие из высказываний истинны, какие — ложны Укажите правильный вариант ответа:Понедельник - первый день недели 4+3=5 Тигр - домашнее животное Зайцы...
Yoma5
27.08.2020 09:52
Чтобы ввести информацию в оперативную память используют устройства ввода информации – это клавиатура, , сканер и другие....
Ru5829
01.05.2022 15:29
Придумайте нахождения самой легкой и самой тяжелой из 100 монет, если можно сделать не более 150 взвешиваний на чашечных весах без гирь...
Алуопо
30.10.2021 22:22
Примеры перехода от хаоса к порядку в окружающем мире...
risimonenko
27.11.2021 01:52
решить квадратное уравнение:...
0p3n
01.02.2021 10:07
9563582+1738473= 7354784+744638=...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
MAX_SIZE = 200;
var
N, Max, i: integer;
X: array [1..MAX_SIZE] of integer;
begin
randomize;
write('N = ');
readln(N);
writeln('Исходный массив: ');
for i := 1 to N do
begin
X[i] := random(101)-50;
write(X[i], ' ');
end;
writeln;
Max := X[1];
for i := 1 to N do
if (X[i] > Max) then
Max := X[i];
writeln('Максимальный элемент массива = ', Max);
end.