В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
tweetyz
tweetyz
23.01.2021 18:08 •  Информатика

Дано пятизначное число n.составьте программу получения нового числа, в котором цифры будут идти в обратном порядке.(без цикла)

Ответ:
1Err0r1
1Err0r1
08.10.2020 09:07
program Revers5;
Var
a,b,c,d,e,n:integer;
begin
write('Введите 5-значное число: ');
readln(n);
a:=n mod 10;
n:=n div 10;
b:=n mod 10;
n:=n div 10;
c:=n mod 10;
n:=n div 10;
d:=n mod 10;
n:=n div 10;
e:=n;
n:=10000*a+1000*b+100*c+10*d+e;
writeln('Реверс введенного числа - ',n);
end.

Дано пятизначное число n.составьте программу получения нового числа, в котором цифры будут идти в об
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?