В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Написать программу на паскале, которая будет считать сумму и среднее арифметическое 10 чисел, введенных массивом, используя процедуры или функции

Ответ:
angelinamikhay
angelinamikhay
08.10.2020 08:34
//Язык Pascal

Program Test;

var
Mas: array[1..10] of integer;
result1: integer;
result2: real;

function Sum(): integer;
var summa: integer;

begin
summa := 0;

for var i := 1 to 10 do
summa := summa + Mas[i];

Sum := summa;
end;

procedure Arifmetic(r1: integer; var A: real);
begin
A := r1 / 10;
end;

Begin

for var i := 1 to 10 do
begin
Write('Введите ', i, ' элемент: ');
Readln(Mas[i]);
end;

result1 := Sum();
Arifmetic(result1, result2);

Writeln();
Writeln('Сумма = ', result1);
Writeln('Среднее арифметическое = ', result2);

End.
Написать программу на паскале, которая будет считать сумму и среднее арифметическое 10 чисел, введен
Написать программу на паскале, которая будет считать сумму и среднее арифметическое 10 чисел, введен
Написать программу на паскале, которая будет считать сумму и среднее арифметическое 10 чисел, введен
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?