Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
danilsalnikov
10.10.2021 06:18 •
Информатика
Найти все целые трёхзначные числа сумма цифр которых равна 6.pascal abc.
Ответ:
frost09042004ozo97y
08.10.2020 07:16
Var a,b,c,i:integer;
begin
for i:=100 to 999 do
begin
a:= i div 100;
b:= i mod 100 div 10;
c:= i mod 10;
if a+b+c = 6 then writeln(i)
end;
readln
end.
0,0
(0 оценок)
Ответ:
swdw1
08.10.2020 07:16
Var
a,b,c: byte;
Begin
for a := 1 to 9 do
for b := 0 to 9 do
for c := 0 to 9 do
if (a+b+c = 6) then
WriteLn(a,b,c);
End.
Вывод:
105
114
123
132
141
150
204
213
222
231
240
303
312
321
330
402
411
420
501
510
600
0,0
(0 оценок)
Популярные вопросы: Информатика
narutoluffi1
19.02.2022 06:05
Сколько времени потребуется для передачи 3072 кбайта, если скорость передачи 4 мбит/с...
kaanekiken
21.01.2021 07:54
Напишите программу для вычисления площади, периметра и высоты треугольника...
Татьяна64101
19.02.2022 06:05
Составить программу в паскале по решению функции x в квадрате + 5 при x 3 x-8 при x меньше или равно трем...
ArseniiB1
26.01.2020 14:10
Найдите объем файла если известно время 10 секунд частота дискретизации 22, 5 размер 8 бит...
burdyugova48
01.04.2023 13:52
Характеристика присудка слова снився...
HИKTO
03.05.2023 01:50
решить 9 класс Л. Г. Овчинникова...
kopil199420p017kl
01.11.2022 02:47
Информатика 8 класс паскаль написать текст: двузначное положительное целое число, если меньше 20 - находим сумму цифр,иначе ничего с рим не делаем...
гилеваКсения
21.02.2022 13:13
PYTHON. Коту снится, что его окружили тринадцать мышей. Двенадцать из них серые, а одна белая. С какой мыши ему начать счет, если он съедает каждую тринадцатую, а белую...
ftf3
01.08.2022 13:15
Задание 6. Чему будет равно N после выполнения алгоритма. а) Начало N = 5; N = N + 2: N = N * 3: Конец. б) Начало N = 12; N = N – 2; N = N * 5; Конец....
erlan002
30.09.2020 01:51
Во сколько раз увеличиться число 26,14(10) при переносе запятой на один знак вправо ?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
for i:=100 to 999 do
begin
a:= i div 100;
b:= i mod 100 div 10;
c:= i mod 10;
if a+b+c = 6 then writeln(i)
end;
readln
end.
a,b,c: byte;
Begin
for a := 1 to 9 do
for b := 0 to 9 do
for c := 0 to 9 do
if (a+b+c = 6) then
WriteLn(a,b,c);
End.
Вывод:
105
114
123
132
141
150
204
213
222
231
240
303
312
321
330
402
411
420
501
510
600