Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
dianashabaneh
02.01.2023 13:55 •
Информатика
Написать программу, определяющую сумму/количество элементов массива, значение которых больше 1 и меньше 5. на языке с++
Ответ:
nekish21
08.10.2020 07:06
#include <iostream>
#include <array>
#include <numeric>
using namespace std;
const size_t N = 10;
int main()
{
size_t sum = 0;
array<int, N> a = { 1, 5, 9, 6, 3, 0, 1, 4, -2, 4 };
cout << "Count: ";
cout << accumulate(a.cbegin(), a.cend(), 0, [&sum](size_t count, const int
num) {
if (num > 1 && num < 5) {
++count;
sum += num;
}
return count;
});
cout << " Sum: " << sum << endl;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
VERONIKA75498768783
12.05.2020 07:04
Придумайте свою цепочку преобразований произвольного числа, такую, чтобы в результате всегда получалось 5....
РумакСтепан
23.12.2022 18:21
По блок-схеме составить программу на языке Паскаль....
Авитя1
11.02.2022 13:22
Даны четыре целых числа, записанных в различных системах счисления: 2308, 2278, 100111002, 100110002. Сколько среди них чисел, которые меньше чем 9B16?...
ilyamam07
13.08.2020 09:21
Дана непустая последовательность целых чисел, оканчивающихся нулём. Найди сумму чисел последовательности больших числа x...
Nikita0228
25.11.2022 15:39
С какой целью в некоторых файловых системах характеристики файла отделяются от его имени ? А) позволяет вкл файл в несколько каталогов б ) файлу можно присвоить несколько разных...
gerasimooffq
24.07.2022 15:52
Найдите правильное решение данной задачи: Напишите код программы которая после ввода вашего имени с клавиатуры, имя печатается 10 раз и печатает слово готово A. name=input() for...
cvacvadav
13.05.2023 10:19
Какие примеры относятся к задаче ассоциации? 1) рекомендательные системы 2) сжатие изображений 3) расстановка товаров на полках 4) прогноз акций и распродаж...
FrozeFre
07.02.2022 17:57
Напишите сценарий к мультику. (Несколько сцен 4-5)...
дашадашадашадаша1
01.02.2023 15:35
Модем який передає дані 30000 біт/с. може передати файл (фотографію) розміром 1 М байта за...
кика20052
07.07.2020 18:53
Определите значение переменной x после выполнения фрагмента программы: a:=2; x:= a + 2; if x 4 then x := x + 2 * a; if x =4 then x:=a-2;...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
#include <array>
#include <numeric>
using namespace std;
const size_t N = 10;
int main()
{
size_t sum = 0;
array<int, N> a = { 1, 5, 9, 6, 3, 0, 1, 4, -2, 4 };
cout << "Count: ";
cout << accumulate(a.cbegin(), a.cend(), 0, [&sum](size_t count, const int
num) {
if (num > 1 && num < 5) {
++count;
sum += num;
}
return count;
});
cout << " Sum: " << sum << endl;
}