В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kristimilafffka
kristimilafffka
13.05.2022 03:29 •  Информатика

Написать программу для вычисления суммы числел от a до b (где a< =b) указание: переменная, которая будет накапливать сумму в начале должна быть равна нулю

Ответ:
kamilla126
kamilla126
08.10.2020 03:35
1. Современное решение

// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadInteger2('Введите через пробел a и b:');
  Writeln('S=',Range(a,b).Sum)
end.

Пример
Введите через пробел a и b: 5 18
S=161

2. К сожалению, все еще часто типичный для школы вариант

var
  a,b,i,s:integer;
 
begin
  Write('Введите через пробел a и b: ');
  Read(a,b);
  s:=0;
  for i:=a to b do
    s:=s+i;
  Writeln('S=',s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?