В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
112234848
112234848
19.02.2022 02:17 •  Информатика

Написать программу : 1. имеется набор состоящий из натуральных чисел определите макси- мальное число, кратное 5. программа получает на вход количество чи- сел в последовательности, а затем сами числа. 2. имеется набор состоящий из натуральных чисел определите сумму чисел, оканчивающихся на 4. программа получает на вход количество чисел в последовательности, а затем сами числа. 3. имеется набор состоящий из натуральных чисел определите сумму чисел, кратных . программа получает на вход количество чисел в по- следовательности, а затем сами числа. 4. имеется набор состоящий из натуральных чисел найдите сумму всех чисел, кратных 6 и оканчивающихся на 4. числа последователь- ности определите с генератора случайных чисел random(x).

Ответ:
leramoisejenko
leramoisejenko
08.10.2020 02:16
// PascalABC.NET 3.3

begin
  var n:=ReadInteger('n = ');
  var a:=ReadArrInteger('Введите '+n+' чисел:',n);
  Writeln('1. максимальное число, кратное 5 = ',
           a.Where(x->x mod 5=0).Max);
Writeln('2. сумма чисел, оканчивающихся на 4 = ',
           a.Where(x->x mod 10=4).Sum);
  Writeln('3. сумма чисел, кратных 7 = ',a.Where(x->x mod 7=0).Sum);
  var b:=ArrRandom(n,10,90).Println;
  Writeln('4. сумма всех чисел, кратных 6 и оканчивающихся на 4 = ',
    b.Where(x->(x mod 6=0)and(x mod 10=4)).Sum);
end.

Пример:
n =  30
Введите 30 чисел: 73 81 14 32 26 20 26 83 36 39 69 22 10 75 24 47 40 12 27 20 78 15 72 18 83 59 40 89 47 87
1. максимальное число, кратное 5 = 75
2. сумма чисел, оканчивающихся на 4 = 38
3. сумма чисел, кратных 7 = 14
84 57 88 50 41 85 28 15 47 48 46 69 41 56 89 19 54 74 33 58 83 66 40 35 89 80 12 86 46 14
4. сумма всех чисел, кратных 6 и оканчивающихся на 4 = 1384. сумма всех чисел, кратных 6 и оканчивающихся на 4 = 0
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?