Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
dvladimirov425
16.10.2022 18:48 •
Информатика
Нужно для программы pascal! из чисел от 10 до 99 вывести те, сумма цифр которых равна n и само число делится на m.
Ответ:
87056231946
08.10.2020 01:56
Var n,m,s,q,w,e:Integer;
begin
Read(n,m);
for s:= 10 to 99 do
begin
q:= s div 100;
w:= s div 10 mod 10;
e:= s mod 10;
if (q+w+e=n) and(s mod m = 0) then
WriteLn(s);
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
nazek121992
02.06.2020 03:15
Выделите компьютерные объекты файл папка рабочий стол компьютерная мышь окно программы...
ОМЛА
25.05.2020 21:44
Составить программу в pascal, используя цикл с счетчиком for 1. напечатать квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b 10) 2. напечатать все целые...
Daniela080722
14.08.2021 12:08
1) присутствие веснушек на лице человека определяется доминантным геном, а их отсутствие - рецессивным. обозначьте генетическими символами следующие характеристики: отсутствие...
milena195
14.08.2021 12:08
Найдите значение выражения (1-1,4*1,5)/(-2)...
Julianne11
14.08.2021 12:08
Составьте предложения так, чтобы ниже слова были разными частями речи и писались по-разному: (в) силу, (в) течени(е, и), (на) конец, (за) то, так (же), (за) тем, (по) тому,...
матиматик31
14.08.2021 12:08
Из данных предложений сделать предложения,в косвенной речи. 1)remember that there are some subjects that are so important that everyone has to study them seriously. 2) make...
coldon
14.08.2021 12:08
Как найти площадь рисунка в виде капли...
Simps0n
14.08.2021 12:08
Моя любимая книга на казакском языке сочинение...
Victoria200188
14.08.2021 12:08
Среднее арифметическое трёх чисел 1,96. первое число в 1,7 раза меньше второго, а третье число больше второго на 0,6. - как решить...
vanyushagay96
14.08.2021 12:08
Два поезда одновременно вышли навстречу драг другу из двух городов, растояние между которыми 495 км. через 3 ч. они встретелись. какова скорость каждого поезда, если известно,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
Read(n,m);
for s:= 10 to 99 do
begin
q:= s div 100;
w:= s div 10 mod 10;
e:= s mod 10;
if (q+w+e=n) and(s mod m = 0) then
WriteLn(s);
end;
end.