В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
CrazyMashin
CrazyMashin
22.10.2020 01:50 •  Информатика

Нужно написать программу на pascal abc net. суть программы такова, что нужно человеку сначала ввести n чисел, после чего программа должна сложить данные числа и эту сумму поделить на сумму чисел в числе,которое получилось в первой сумме, когда человек вводил числа. формула: где sum1= сумму n чисел, которые ввёл человек sum2=сумму чисел в числе, получившееся в результате сложения чисел, вводимых человеком. 100 за написание такой программы!

Ответ:
LILIAGNATIV
LILIAGNATIV
21.08.2020 11:30
// PascalABC.NET 3.3

begin
  var n:=ReadInteger('n =');
  var a:=ReadSeqInteger('Введите '+n+' чисел: ',n);
  var sum1:=a.Sum;
  var x:=sum1;
  var sum2:=0;
  while (x>0) do 
   begin
   sum2:=sum2+x mod 10;
   x:=x div 10;
   end;
  writeln('sum1 = ',sum1,' sum2 = ',sum2,' sum1/sum2 = ',sum1/sum2);
end.

Пример:
n = 5
Введите 5 чисел:  2 7 4 3 5
sum1 = 21 sum2 = 3 sum1/sum2 = 7
Нужно написать программу на pascal abc net. суть программы такова, что нужно человеку сначала ввести
0,0(0 оценок)
Ответ:
саня30970
саня30970
21.08.2020 11:30
Ну должно быть как то так .
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?