В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
KekalolQ
KekalolQ
27.09.2021 03:28 •  Информатика

Водномерном массиве вычислить долю четных положительных элементов массива. написать программу на с#.

Ответ:
Julia517517
Julia517517
08.10.2020 01:14
Static void Main(string[] args)       
{           
     int count = 0;           
     Console.Write("Введите размерность массива: ");           
     int n = Convert.ToInt32(Console.ReadLine());           
     int[] mas = new int[n];           
     Console.WriteLine("Заполните массив: ");           
     for (int i = 0; i < n; i++)           
     {               
          Console.Write("\t{0} элемент массива: ", i + 1);             
          mas[i] = Convert.ToInt32(Console.ReadLine());           
     }           
     for (int i = 0; i < n; i++)               
          if (mas[i] > 0 && mas[i] % 2 == 0)                   
               count++;           
     Console.WriteLine("Из {0} элементов массива {1} элементов являются положительными четными",n,count);           
     Console.WriteLine("{0}%  элементов являются положительными четными", (double)count/n*100);           
     Console.ReadLine();       
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?