В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Киря2006555
Киря2006555
27.01.2021 13:03 •  Информатика

Выведите все элементы массива с: а) нечётными индексами (то есть A[1], A[3], A[5], ...);

б) чётными индексами (то есть A[0], A[2], A[4], ...).

Формат входных данных

Вводится количество элементов в массиве. Далее вводятся элементы массива.

Формат выходных данных

Выведите ответ на задачу.

Sample Input:

5

1

2

3

4

5

Sample Output:

1 3 5

Ответ:
Яна2005561
Яна2005561
22.12.2020 23:42

int[] mas;

int n;  

n = Convert.ToInt32(Console.ReadLine());

mas = new int[n];

for (int i = 0; i < mas.Length; i++)

mas[i] = Convert.ToInt32(Console.ReadLine());

Console.WriteLine();

Console.WriteLine("Элементы с чётными индексами:");

for (int i = 0; i < mas.Length; i = i + 2)

{    

Console.WriteLine(mas[i]);

}

Console.WriteLine();

Console.WriteLine("Элементы с нечётными индексами:");

for (int i = 1; i < mas.Length; i = i + 2)

{

Console.WriteLine(mas[i]);

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?