В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
лиза2699
лиза2699
09.01.2022 22:04 •  Информатика

Паскаль написать программу: на вход программы числа соответствующие длинам сторон многоугольника. ввод заканчивается при введении отрицательного числа или 0. необходимо посчитать периметр этого многоугольника и вывести на экран сообщение "периметр n-угольника равен ", где вместо n должно быть указано какой это многоугольник (3-угольник, 4-угольник и тд).

Ответ:
heni2001
heni2001
30.04.2020 14:48
//PascalABC.NET
//Версия 3.3, сборка 1634
begin
var a:=ReadSeqIntegerWhile(x->x>0).ToArray;
write('Периметр ', a.Count,'-угольник равен ',a.Sum);
end.
0,0(0 оценок)
Ответ:
Лилиана4312
Лилиана4312
30.04.2020 14:48
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (P,n):=(0.0,0);
  ReadSeqRealWhile(t->t>0).Foreach(t->begin P+=t; n+=1 end);
  Writeln('Периметр ',n,'-угольника равен ',P)
end.

Пример
4.7 2.9 6.2 1.8 5 0
Периметр 5-угольника равен 20.6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?