В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sksjdjdjxk
sksjdjdjxk
10.01.2020 10:28 •  Информатика

Составьте программу в паскале для поиска: a)суммы положительных элементов массива от а от 1 до 100, введенных с клавиатуры b) произведения отрицательных элементов массива а от 1 до 100 c) количества нулевых элементов массива с сотней элементов

Ответ:
kgrdva
kgrdva
07.10.2020 22:05
А) uses crt;
const n=10;
var a:array[1..n] of integer;   
i,sum:integer;
begin
for i:=1 to n do   
begin         
a[i]:=random(100)-50;         
write(a[i]:4);         
if a[i]>0 then sum:=sum+a[i];   
end;
writeln;
writeln('Сумма положительных элементов = ',sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?