Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
Показать больше
Показать меньше
Ynushkevich333
22.12.2021 20:41 •
Информатика
Масса каждого из 25 человек хранится в массиве людей, имеющих массу более 100 кг будем условно называть полными (известно,что есть по меньшей мере один такой человек). определите среднюю массу полных людей, и среднюю массу остальных людей
Ответ:
alina1934
07.10.2020 21:40
//PascalABC.NET
//Версия 3.3, сборка 1627 (27.01.2018)
begin
var l:=ArrRandom(25,50,150); l.Println;
Writeln('Среднее полных-> ',l.Where(t->t>=100).Average:0:4);
Writeln('Среднее остальных-> ',l.Where(t->t<100).Average:0:4);
end.
Пример:
55 108 131 58 141 62 102 56 118 78 128 114 110 66 134 74 71 56 103 126 76 133 118 99 101
Среднее полных-> 119.0714
Среднее остальных-> 68.2727
0,0
(0 оценок)
Популярные вопросы: Информатика
Gafana
01.10.2020 09:48
Подсчитать количество и сумму четных четырехзначных чисел pascal abc...
маша9393
01.10.2020 09:48
Даны числа целого типа заданные с клавиатуры выяснить сколько среди них нечетных.найти их сумму условием окончания ввода служит 0...
moroshan77
15.12.2021 20:39
Составить программу на паскале. расчитать доход за весь гот по месяцам. пример: в первый месяц мы получили 100р, во второй 102р. но! учесть что и проценты тоже растут....
Timyr1020
15.12.2021 20:39
1)var s,k,i: integer; begin s=0 for k : = 3 to 8 do s : = s + 9; writeln(s); end. 2)var s,k,i: integer; begin s=100 for k : = 1 to 9 do s : = s - 5; write(s); end. 3)var...
Sanyaiftkfjycycyccy
15.12.2021 20:39
Составить блок схему. (в тетради). дано трёхзначное число n. подсчитать количество единиц в записи этого числа....
nizomabdurahmon
13.05.2022 23:48
..Для копирования однотипных расчетов в клетки соответствующего Диапазона используют... 1элементы управления Ленты 2абсолютные ссылки 3маркер автозаполнения 4условное...
Алтынбек05
11.05.2022 09:07
Укажи наименьшее целое число X, для которого истинно высказывание...
senyadubra
15.03.2020 07:59
Укажите какой тип ссылки: D$12 а)Абсолютные б)Относительныев) Строчные г)Мишаные...
з1з1
20.09.2020 16:33
9. К расширениям архивированным файлом относится а) 72, rar, arj, pkg, tar 6) bas, pas, cal в) pps, ppt, pptx г) sys, bak д) gif, bmp, jpg...
annya306
04.01.2022 22:07
Какие наборы математических символов используют в формулах? Как вставить нужный символ?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
//Версия 3.3, сборка 1627 (27.01.2018)
begin
var l:=ArrRandom(25,50,150); l.Println;
Writeln('Среднее полных-> ',l.Where(t->t>=100).Average:0:4);
Writeln('Среднее остальных-> ',l.Where(t->t<100).Average:0:4);
end.
Пример:
55 108 131 58 141 62 102 56 118 78 128 114 110 66 134 74 71 56 103 126 76 133 118 99 101
Среднее полных-> 119.0714
Среднее остальных-> 68.2727