В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kamilla198
kamilla198
07.09.2020 00:02 •  Информатика

Написать программу для pacsal. заданы два целых числа найти сумму их последних цифр.

Ответ:
sqerrr
sqerrr
07.10.2020 17:14
1. Современное решение с числами произвольной длины

// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var s1:=ReadlnString('1-е число:');
  var s2:=ReadlnString('2-е число:');
  Writeln('Сумма последних цифр: ',s1.Right(1).ToInteger+s2.Right(1).ToInteger)
end.

Пример
1-е число: 23454577562342341234213141652
2-е число: 35645675786956323224
Сумма последних цифр: 6

2. Типовое "школьное" решение

var
  a, b: integer;

begin
  Write('Введите два числа через пробел: ');
  Read(a, b);
  Writeln('Сумма последних цифр: ', a mod 10 + b mod 10)
end.

Пример
Введите два числа через пробел: 435345
6342
Сумма последних цифр: 7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?