Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
VZ1
19.01.2020 21:13 •
Информатика
Составить программу на языке паскаль ввести с клавиатуры вещественное число a и целое число n (> 0). вывести все целые степени числа a от 1 до n.
Ответ:
Юмилия
26.08.2020 21:08
Var a,an:real; n,i:integer;
begin
readln(a,n);
an:=1;
for i:=1 to n do
begin
an:=an*a;
writeln(a:3:2,'^',i,' = ',an:6:3);
end;
end.
Пример:
2.0 5
2.00^1 = 2.000
2.00^2 = 4.000
2.00^3 = 8.000
2.00^4 = 16.000
2.00^5 = 32.000
0,0
(0 оценок)
Ответ:
anyaadamchuk2
26.08.2020 21:08
Var
a: real;
n: integer;
begin
read(a, n);
for var k := 1 to n do
begin
write(power(a, k), ' ');
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
макс3113
29.12.2020 22:22
перевести число 8611 из десятичной в пятеричную и восьмеричную системы С РЕШЕНИЕМ...
valera123zeerow4kam
02.06.2020 10:15
С++Напишите программу, которая печатает все числа от 0 до 6, кроме 3....
KosherDan
20.03.2020 22:35
Напишите программу на C ++, чтобы проверить, является ли число простым или нет....
Косинус08111
27.12.2020 12:22
Программа на C ++ для нахождения суммы всех целых чисел от 100 до 200, которые делятся на 9....
Маминбандит138
11.12.2021 18:40
Даны два действительных положительных числа x и y. арифметические действия над числами пронумерованы (1-сложение, 2-вычитание, 3-умножение, 4-деление). составить программу,...
1234567890859
11.12.2021 18:40
Вкоробке лежат кубики 6 красных 7 зелёных 12 синих какое количество информации будет получено при извлечении зелёного кубика? при извлечении кубика любого цвета?...
Dancerebuclic2017
20.04.2020 14:12
Построить таблицу истинности для логического выражения! нужно...
Fantom511
14.09.2022 13:10
От верёвки длиной 27 метров отрезали 0.7 её длины, а потом отрезали 2/9 остатка. сколько метров верёвки осталось после этого...
EseniaVoznesenskaya
14.09.2022 13:10
1.причины могущества империи 2.назовите 4 главных каст в индии, и укажите род занятий подходящий для каждого из них 3.культурные достижения в древней индии наука,изобретение,исскуство)...
polina260505
14.09.2022 13:10
Найдите среди чискл 1 2/7 3 1/2. 7/9. 7 1/2 взаимно обратные 30...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
readln(a,n);
an:=1;
for i:=1 to n do
begin
an:=an*a;
writeln(a:3:2,'^',i,' = ',an:6:3);
end;
end.
Пример:
2.0 5
2.00^1 = 2.000
2.00^2 = 4.000
2.00^3 = 8.000
2.00^4 = 16.000
2.00^5 = 32.000
a: real;
n: integer;
begin
read(a, n);
for var k := 1 to n do
begin
write(power(a, k), ' ');
end;
end.