В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
KosherDan
KosherDan
20.03.2020 22:35 •  Информатика

Напишите программу на C ++, чтобы проверить, является ли число простым или нет.​

Ответ:
lisablida
lisablida
13.04.2021 11:17

# include <iostream>

# include <stdio.h>

 

void main(void)

{      float k; int l,n;

       l=0;

std::cout<<"ww chislo n=";

std::cin>>n;

 

 

 

for(int i=2;i<n-1;i++){

k=n/i;

if (k==int(k))

l=l+1;

else

l=l;

}

if (l>=1)

std::cout<<"chislo ne proste";

else

std::cout<<"chislo n="<<n<<" proste";

 

 getchar();getchar();

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?