Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Teacher991
03.01.2020 06:10 •
Информатика
Pascal .заменить 1-й элемент одномерного массива на среднее значение его элементов.
Ответ:
diana02lili
21.08.2020 08:56
//PascalABC.NET 3.3,сборка 1611 от 06.01.2018
//Внимание! Если программа не работает, обновите версию!
begin
var a:=1.0;
var n:=readinteger('n=');
var mas:=ArrRandomReal(n,-99,99);
var h:=mas.Select(t->round(t*100) /100).ToArray; h.Println;
for var i:=0 to n-1 do
a:=a*h[i];
a:=a*(1/n);
h[0]:=a;
writeln('среднее неометрическое =',a);
h.println;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Motornerplay
07.03.2023 10:30
Информатика Напишите, какие действия будут происходить в каждой строке предложенной программы?...
Lilic1503ld
06.06.2023 07:28
Какое наименьшее натуральное число необходимо подать на вход алгоритма, чтобы в результате его выполнения было напечатано сообщение «Yes»?ВВодаесли (а + 1 ) mod...
flash2050p08smf
12.01.2022 02:11
Кто знает только без спама и лишнего! Пользователь вводит целое число с клавиатуры. Написать программу, которая проверяет введенное число, если число больше 0 программа...
lyagaeva87
28.11.2022 15:01
Какое значение будет выведено на печать после выполнения выражения r=pow(abs(-2) + abs(-1), round(3,8)) print(r) ...
slyzova1
13.08.2022 04:51
Синтез логических выражений! по таблице получается выражение x = ¬a& b& c+a& b& ¬c+a& b& c буду !...
Viktor15102
29.06.2021 09:48
Нарисуйте мне как вот это будет плес. блок-схему нужно var a: integer; b: string; begin readln(a); b : = inttostr(a); writeln(length(b)); end. или по своему решите...
yagunovaliza
02.03.2020 21:28
30 ! сообщение по информатике на тему виды информации и свойства...
Ilka1k
02.03.2020 21:28
Книга состоит из 600 страниц, на каждой странице 36 строк, по 64 сиивола. за сколько времени можно передать по сети данную кнтгу при скорости 64 кб/с?...
iyamelnitska
02.03.2020 21:28
Cоставить блок схему: вводится последовательность чисел, надо найти сумму этих чисел, зная то что ввод заканчивается при встрече нуля...
vika36voronezhskaya
16.01.2023 03:57
Написать программу на паскале, которая будет считать сумму и среднее арифметическое 10 чисел, введенных массивом, используя процедуры или функции...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
//Внимание! Если программа не работает, обновите версию!
begin
var a:=1.0;
var n:=readinteger('n=');
var mas:=ArrRandomReal(n,-99,99);
var h:=mas.Select(t->round(t*100) /100).ToArray; h.Println;
for var i:=0 to n-1 do
a:=a*h[i];
a:=a*(1/n);
h[0]:=a;
writeln('среднее неометрическое =',a);
h.println;
end.