Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
katiapopovici
07.07.2020 04:58 •
Информатика
Заполнить двумерный массив по правилу: а) 1 0 1 0 1 1 0 1 0 1 1 0 1 0 1 1 0 1 0 1 б) 1 2 3 4 5 1 2 3 4 5 1 2 3 4 5 1 2 3 4 5 в) 1 2 3 4 5 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 г) 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0
Ответ:
ПомощникКоторыйЛюбит
26.08.2020 20:56
// PascalABC.NET 3.3, сборка 1600 от 23.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('a)');
var m:=MatrGen(4,5,(i,j)->j.IsEven?1:0); m.Println(2);
Writeln('б)');
m:=MatrGen(4,5,(i,j)->j+1); m.Println(2);
Writeln('в)');
m:=MatrGen(4,5,(i,j)->i=0?j+1:5*(i+1)+j+1); m.Println(3);
Writeln('г)');
m:=MatrGen(4,5,(i,j)->(i+j).IsOdd?0:1); m.Println(2);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
meli12341
30.12.2021 17:41
Логические выражения: a& ¬bvb& cv¬a& ¬b...
Anytohka0cosmos
30.12.2021 17:41
Сколько времени будет передаваться файл объемом 15мб по каналу передачи информации со скоростью 4 мбит/с?...
rudnfc
30.12.2021 17:41
Какое количество цветов можно закодировать, используя на код одного цвета 8 бит?...
miloft
30.12.2021 17:41
Максимальный объем списка из 200 фамилий, самая длинная из которых состоит из 12 букв, выраженных в кбитах. ответ округлить до целого значения....
MRS1CATHERINAAA
06.10.2022 01:04
8-цветное растровое изображение размером 128x256 пикселей сохранили в виде несжатого файла, закодировав каждый пиксель минимально возможным количеством бит. каков размер получившегося...
sakyra225
08.02.2020 21:35
Распечатать на паскале первые nчетных чисел,заранее пасибо...
Derety11
23.04.2023 00:47
Составить программу расчёта произведений элементов массива...
nizomabdurahmon
23.04.2023 00:47
Какое сочетание клавиши используется для отправки рисунка на печать?...
Kakation
23.04.2023 00:47
Составить программу расчёта произведения элементов массива; найти в нём минимальный элемент и его номер...
dionis01
06.06.2021 16:43
Яку ваду людини засуджує Акутагава Рюноске в новелі «Павутинка»: А) зрадництво; Б) присвоєння лише собі шансу на ння; В) зажерливість, жагу до багатства; Г) байдужість до...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('a)');
var m:=MatrGen(4,5,(i,j)->j.IsEven?1:0); m.Println(2);
Writeln('б)');
m:=MatrGen(4,5,(i,j)->j+1); m.Println(2);
Writeln('в)');
m:=MatrGen(4,5,(i,j)->i=0?j+1:5*(i+1)+j+1); m.Println(3);
Writeln('г)');
m:=MatrGen(4,5,(i,j)->(i+j).IsOdd?0:1); m.Println(2);
end.