Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Vad1mm
20.03.2023 10:43 •
Информатика
Запишите программу на языке паскаль которая заполняет массив случайными числами на отрезке от -2 до 2 и считает сумму положительных элементов массива
Ответ:
Zhenya13551
21.08.2020 07:24
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-2,2); a.Println;
Writeln('Сумма положительных равна ',a.Where(t->t>0).Sum)
end.
Пример
n= 10
-1 1 0 2 2 -1 -2 -1 -1 2
Сумма положительных равна 7
0,0
(0 оценок)
Популярные вопросы: Информатика
prostooo202003
04.08.2022 07:31
Решить информатику 1. из ниже предложений выберите высказывания и обоснуйте выбор: а) выхожу один я на дорогу б) я спросил у ясеня: где моя любимая? в) зачем вы, девушки, красивых...
matve228
04.08.2022 07:31
Уставку росте один аркуш лілії. кожен день число листя подвоюється. на який день ставок буде покритий листям лілії наполовину, якщо відомо, що він буде повністю покритий ними через...
Умару11
15.10.2021 02:19
Найти,какое число обозначает каждая буква,если известно,что: 1.а равно сумме з и к. 2. к в з раза меньше л. 3.л равно сумме м и о. 4. m равно разности н и р. 5. н второе больше...
Aruzhankaaaaa1
07.01.2020 08:40
Unine Niektep - Bilimia X +https:/fonlinemektep.net/schedule/10.03.2021/lesson/f9a32003 a 06-4040 86dc 07bbfagielcaЗАДАНИЕ No5Эхника ВРЕМЯ НА ВЫПОЛНЕНИЕ: х.13:19op ypokaТЕКСТ ЗАДАНИЯКание...
соня1581
06.09.2021 05:02
Установите соответствие между пунктами меню IDE Python и подпунктами Run Edit File УМОЛЯЮ ...
Шпсхрчз
20.10.2020 00:41
Напишите программу для решения задачи в PASCALABC. Предусмотрите ввод исходных данных и проверку на ограничения, заданные в условии. Задание: Дано два четырехзначных числа. Определите,...
мппьга
19.07.2022 16:52
Понимание 1. Почему в среде программирования Scratch мы исполь- зуем разные виды алгоритмов? 2. Почему при создании скриптов ставится условие? 3. Почему возникает необходимость...
MrLech
11.01.2020 03:13
Введите верный ответ. Три учительницы: Инга Петрова, Татьяна Михайлова, Светлана Андреева преподают: ботанику, музыку и черчение в школах Москвы, Ужгорода и Твери. Известно что:...
InvisibleGuеst
07.04.2023 05:20
написать программу на C++Оформить функцию поиска количества нулевых элементов массива. В главной программе дано 3 одномерных массива arr1,arr2,arr3 длиной 10 элементов каждый....
skyline12345
21.09.2021 08:47
Как узнать верные ответы для тестовой работы в exel?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-2,2); a.Println;
Writeln('Сумма положительных равна ',a.Where(t->t>0).Sum)
end.
Пример
n= 10
-1 1 0 2 2 -1 -2 -1 -1 2
Сумма положительных равна 7