В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
InvisibleGuеst
InvisibleGuеst
07.04.2023 05:20 •  Информатика

написать программу на C++

Оформить функцию поиска количества нулевых элементов массива. В главной программе дано 3 одномерных массива arr1,arr2,arr3 длиной 10 элементов каждый. Применить функцию для каждого из 3-х заданных массивов. (в функции не должно быть операторов ввода или вывода)

Ответ:
LeНин
LeНин
12.10.2020 20:01

#include <iostream>

using namespace std;

#define n 10

void fillingMass(int arr[n])

{

   for(int i=0; i<n; i++)

   {

       arr[i] = -5 + rand() % 10;

       cout<<arr[i]<<" "; // вывод содержимого массивов, если не надо уберешь

   }

   cout<<endl; // вывод содержимого массивов, если не надо уберешь

}

int countingZero(int arr[n])

{

   int count = 0;

   for(int i=0; i<n; i++)

   {

       if(arr[i] == 0)

           count++;

   }

   

   return count;

}

int main()

{

   int arr1[n],arr2[n],arr3[n];

   fillingMass(arr1);

   fillingMass(arr2);

   fillingMass(arr3);

   

   cout<<"In the first array, the number of zero elements = "<<countingZero(arr1)<<endl;

   cout<<"In the second array, the number of zero elements = "<<countingZero(arr2)<<endl;

   cout<<"In the third array, the number of zero elements = "<<countingZero(arr3)<<endl;

   return 0;

}

Объяснение:


написать программу на C++Оформить функцию поиска количества нулевых элементов массива. В главной про
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?