В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
iNNA9078
iNNA9078
14.10.2020 17:41 •  Информатика

Составте программу, которая формирует массив из 5 целых чисел,элементы массива вводятся вручную с клавиатуры. найдите максимальный элемент в массиве. ответ вывести в формате "мах=".

Ответ:
//Pascal
var
  A: array[1..5] of integer;
  i: byte;
  MAX: integer;
begin
writeln('Заполнение массива.');
for i := 1 to 5 do
begin
  write('A[',i,'] = '); readln(A[i]);
end;
MAX := A[1];
for i := 1 to 5 do
  begin
    if A[i] > MAX then MAX := A[i];
    write(A[i]:4);
  end;
writeln;
writeln('Максимальный элемент в массиве = ', MAX);  
readln;
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?