Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
fire31
25.07.2022 04:08 •
Информатика
Нужно написать программу, которая определяет, является ли целое число простым. на уровне 9 класса, попроще что бы было. в паскале. заранее !
Ответ:
Vlad584q
08.10.2020 14:55
Program p1;
uses crt;
var a,b:integer;
begin
read(a);
If (a mod 2 = 0) and (a <> 2) or (a mod 3 =0)and (a <> 3) or (a mod 5 = 0) and (a <> 5)or (a mod 7 = 0) and (a <> 7) then
write(a,' непростое число')
else
write(a ,' простое число');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
gothalk2014
27.05.2021 12:25
Даны три целых положительных числа a, b и c. выбрать из них то число, сумма делителей которого максимальна....
ладаседан7
14.10.2021 12:21
Paskal даны два комплексных числа a и b. найти из них наибольшее и наименьшее по модулю комплексное число. указание: реализовать подпрограммы ввода, вывода комплексного числа, модуля...
Ира1656
01.04.2023 03:24
Даны натуральное число n, целые числа a25, bn. среди a25 нет повторяющихся чисел, нет их и среди bn. построить объединение данных последовательностей...
LilauSen
26.02.2022 01:11
Надо сделать в Excel I. Финансовые функции.Создайте лист «Финансовые функции», решите приведенные задачи. По возможности используйте имена ячеек.1. Вы получили предложение вложить...
Zavgorodnev04
27.07.2022 18:56
Какие инструменты есть в разделе меню «Камера»? Инструменты модификации Инструменты рисования Основные инструменты Инструменты навигации...
Tess85
21.11.2021 05:19
Как называются люди которые делают игры?...
Dmutrenkovladuslav12
30.04.2021 06:01
с++ дано два числа a и b. найдите гипотенузу треугольника с заданными катетами. входные данные в двух строках вводятся два числа (числа целые,положительные, не превышают 1000)....
qwerty836
30.04.2021 06:01
Составте алгоритм например : готовка борща, 1 налить воду в кастрюлю. 2 порезать мясо и т.д , но мне нужно алгоритм другого действия...
Призванный
07.02.2023 00:04
Найдите художественные средства. Определите их функцию. делал икар...
МАМБЭТ
26.02.2020 17:26
Разложите на множители az^2-bz^2+az-bz +a-b ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
uses crt;
var a,b:integer;
begin
read(a);
If (a mod 2 = 0) and (a <> 2) or (a mod 3 =0)and (a <> 3) or (a mod 5 = 0) and (a <> 5)or (a mod 7 = 0) and (a <> 7) then
write(a,' непростое число')
else
write(a ,' простое число');
end.