В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
LUCOVERUS
LUCOVERUS
25.01.2021 15:10 •  Информатика

Программу в pascal abc 1. дано целое число а. если значение а > 0, то необходимо увеличить его на единицу. напи-сать программу для решения этой . программа должна иметь дружественный интерфейс. про-тестировать программу для a=5, a=-4, a=0. 2. дано целое число а. если значение а < 0, то необходимо удвоить его. написать программу для решения этой . программа должна иметь дружественный интерфейс. протестировать про-грамму для a=6, a=-10, a=0. 3. дано целое число а. если значение а < > 0, то необходимо уменьшить его на 4. написать программу для решения этой . программа должна иметь дружественный интерфейс. протести-ровать программу для a=2, a=-1, a=0. 4. дано целое число а. если значение а > 0, то необходимо увеличить его на единицу, иначе уменьшить на 1. написать программу для решения этой . программа должна иметь друже-ственный интерфейс. протестировать программу для a=3, a=0, a=-12. 5. дано целое число а. если значение а = 0, то необходимо увеличить его на 3, иначе при-своить а значение равное 0. написать программу для решения этой . программа должна иметь дружественный интерфейс. протестировать программу для a=0, a=-1, a=8. 6. даны два действительных числа x и y. если x> y, то вычислить произведение этих чисел, иначе их сумму. программа должна иметь дружественный интерфейс. протестировать программу на трёх различных тестах (x> y, x=y и x

Ответ:
Sasha1234563673727
Sasha1234563673727
07.10.2020 10:09

var

   a: integer;

begin

   {1}

   readln(a);

   if a > 0 then a := a + 1;

   writeln(a);

   

   {2}

   readln(a);

   if a < 0 then a := a * 2;

   writeln(a);

   

   {3}

   readln(a);

   if a <> 0 then a := a - 4;

   writeln(a);

   

   {4}

   readln(a);

   if a > 0 then a := a + 1

   else a := a - 1;

   writeln(a);

   

   {5}

   readln(a);

   if a = 0 then a := a + 3

   else a := 0;

   writeln(a);

end.

{6}

var

   x, y: real;

begin

   readln(x, y);

   if x > y then x := x * y

   else x := x + y;

   writeln(x);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?