В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
SForest
SForest
12.07.2021 00:01 •  Информатика

Слова в тексте разделены пробелом. напишите программу, выводящая количество символов в каждом слове, через pascalabc.

Ответ:
Dinka2103
Dinka2103
07.10.2020 09:40
1)
var s,w:string; p:integer;
begin
readln(s);
s:=s+' ';
p:=pos(' ',s);
while p>0 do
 begin
 w:=copy(s,1,p-1);
 writeln(w,' - ',length(w));
 delete(s,1,p);
 p:=pos(' ',s);
 end;
end.

Пример:
Слова в тексте разделены пробелом
Слова - 5
в - 1
тексте - 6
разделены - 9
пробелом - 8

2)
var s,w:string; k,i:integer;
begin
readln(s);
s:=s+' ';
w:=''; k:=0;
for i:=1 to length(s) do
 if s[i]<>' ' then begin w:=w+s[i]; k:=k+1; end
 else begin writeln(w,' - ',k); w:=''; k:=0; end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?