В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Программа с массивами c++/c. существует массив t[1..n,1..n] с целыми числами. составьте программу, которая будет вычислять произведение ненулевых элементов над диагональю и считать отрицательные элементы под главной диагональю главной матрицы т. 1) и алгоритм решения если можно.

Ответ:
kot291
kot291
07.10.2020 09:39
/*VS C++*/
#include <iostream>
#include <time.h>

using namespace std;

int main() {
    int T[255][255];
    int N, sum, mult;

    cout << "Vvedite N = "; cin >> N;
    cout << "***Random matrix***" << endl;
    srand(time(NULL));

    //Генерация массива
    for (int i = 0; i < N; i++) {
        for (int j = 0; j < N; j++) {
            T[i][j] = rand() % 41 + (-20);
            printf("%4.0d ", T[i][j]);
        }
        cout << endl;
    }

    //Сумма отрицательных над главной
    sum = 0;
    for (int i = 1; i < N; i++) {
        for (int j = 0; j < N; j++){
            if (j == i - 1) {
                if (T[i][j] < 0){
                    sum = sum + T[i][j];
                }
            }
        }
    }
    cout << "Summa = " << sum << endl;

    //Произведение ненулевых под главной
    mult = 1;
    for (int i = 0; i < N; i++) {
        for (int j = 1; j < N; j++) {
            if (j == i + 1) {
                if (T[i, j] != 0) {
                    mult = mult * T[i][j];
                }
            }
        }
    }
    cout << "Proizvedenie = " << mult << endl;
   
    system("pause");
    return 0;
}

Программа с массивами c++/c. существует массив t[1..n,1..n] с целыми числами. составьте программу, к
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?