В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу которая вычисляет сколько раз введенное с клавиатуры число встречается в массиве который нужно ввести с клавиатуры в строчку ( в pascal)

Ответ:
Phkgd
Phkgd
06.10.2020 13:56
program chislo;
var    i,n,x,v : integer;  
 a : array [1..100] of integer;
begin    
 writeln('введите количество элементов n :');    
 readln(n);      
  writeln('введите массив');  
   for i:=1 to n do      
   read(a[i]);    
   writeln('введите число');  
   readln(x);    
   v:=0;  
    for i:=1 to n do  
        if (a[i] = x) then v:=v+1;    
    writeln('встречается ',v);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?