В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mishkasega77798
mishkasega77798
23.03.2023 14:37 •  Информатика

Составить программу в паскале 10 абитуриентов сдали экзамены (максимальная сумма за три экзамена 300). посчитать проходной , если известно, что он составляет 80% от среднего . посчитать количество зачисленных и вывести номера зачисленных абитуриентов.

Ответ:
Denis12121210
Denis12121210
10.08.2020 18:25
Const n=10; m=3;
var 
a:array[1..n,1..m] of integer;
i,j,s,k:integer; p:real;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do
  begin
   a[i,j]:=random(81)+20;
   write(a[i,j]:4);
  end;
  writeln;
 end;
s:=0;
for i:=1 to n do
 for j:=1 to m do s:=s+a[i,j];
p:=s/n*0.8;
writeln('p = ',p:5:2);
writeln('Зачислены:');
k:=0;
for i:=1 to n do
 begin
 s:=0;
 for j:=1 to m do s:=s+a[i,j];
 if s>=p then begin write(i,' '); k:=k+1; end;
 end;
writeln;
writeln('k = ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?