Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
Lolopoknhvkcgc
28.10.2021 22:58 •
Информатика
Паскаль abc! с ! дано многозначное число, проверьте , является ли его сумма четной
Ответ:
Fagga322
10.08.2020 18:13
var
x, sum:integer;
Begin
Write('Введите число '); Readln(x);
while (x > 0) do begin
sum:= sum + x mod 10;
x:=x div 10
end;
if (sum mod 2 = 0)then
Writeln('YES')
else
Writeln('NO');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
antonareninozvuw8
19.03.2020 20:19
Алфавит племени Мумбаса содержит 19 символов. Какое количество информации потребуется чтобы закодировать один символ этого алфавита в двоичном коде?...
Yaritas
04.09.2022 10:00
У Вовы на флешке есть несколько файлов. Можешь определить, к какому типу относится каждый из них? Архив для отправки по электронной почте а) .jpg Презентация к докладу...
ivonin07
24.10.2020 06:11
Составьте программу используя, оператор if: ввести года рождения 3 сестер: аня, оля и лена. определить младшую, среднюю и старшую....
UliaBorodaykevi
09.06.2022 15:40
заполните одномерный массив z квадратами чисел от 4 до 11 pascal...
pepeon11
09.06.2022 15:40
ввести два числа (а, b), если разность чисел b и а отрицательна и делится на 4, то удвоить разность. , .....
BlackZhopa
24.05.2021 11:26
оформить заполнение массива d [1..23]...
karolinaanime
24.05.2021 11:26
Составить программу паскаль, которая выводит на экран олимпийские кольца. , заранее большое )...
mrflotov
17.04.2022 08:00
Сформировать одномерный массив из 15 элементов (значения элементов случайным образом). увеличить элемент в 2 раза, если он стоит на четном месте. вывести на экран...
MrЕвгений228
28.08.2022 10:15
Сформировать одномерный целочисленный массив a размерностью n. запросить у пользователя индекс k и поменять местами элемент a[k-1] и a[k+1]. вывести на экран исходный...
ilmir123456789
28.08.2022 10:15
Склавиатуры вводится четырехзначное число. необходимо подсчитать сумму цифр этого числа...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
x, sum:integer;
Begin
Write('Введите число '); Readln(x);
while (x > 0) do begin
sum:= sum + x mod 10;
x:=x div 10
end;
if (sum mod 2 = 0)then
Writeln('YES')
else
Writeln('NO');
end.