Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
karolinaanime
24.05.2021 11:26 •
Информатика
Составить программу паскаль, которая выводит на экран олимпийские кольца. , заранее большое )
Ответ:
Bab4enock
03.10.2020 12:51
Uses crt,graph;
var
gd, gm, xc, yc, r, x, y: integer;
begin
clrscr;
repeat
writeln('Vvedite koordinaty levogo kolca, x=[50..300], y=[50..350]:');
readln(xc, yc);
until((xc >= 50) and (xc <= 300)) and ((yc >= 50) and (yc <= 350));
gd := 0;
initgraph(gd, gm, '');
setbkcolor(15);
cleardevice;
r := 50;
setlinestyle(0, 0, 3);
setcolor(9);
circle(xc, yc, r);
setcolor(8);{темно-серый, черный не нарисовать}
circle(xc + 2 * r, yc, r);
setcolor(12);
circle(xc + 4 * r, yc, r);
setcolor(14);
circle(xc + r, yc + r, r);
setcolor(10);
circle(xc + 3 * r, yc + r, r);
readln
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
XXL18
11.01.2023 22:06
Подержиться ли PUBG LITE на Pentium...
vitlikkushnirp08qv4
20.06.2020 20:33
На вход в программе подаётся рост 10учеников в сантиметрах, сколько учеников имеют рост выше чем средний C++...
lime89cc
06.09.2020 02:30
Реши и выбери верный ответ. (fat16) в блокнот (notepad) введён текст: конфеты. 1. информационный объём текста равен: байтов 2. занимаемый объём на флэш - диске:...
youlia86
27.05.2021 03:50
Указать через запятую в порядке возрастания все основания систем счисления, в которых запись десятичного числа 37 заканчивается на 5....
Allison5
27.05.2021 03:50
Дано число а=66(в восьмеричной) и b=38(в шестнадцатиричной). определить число с такое, чтобы выполнялось условие а...
oreo228123
27.05.2021 03:50
Автоматическое устройство осуществило перекодировку сообщения из юникод (i1=16 бит) в кои 8. при этом объём стал 60. найдите v1...
kristina231220
22.10.2021 06:28
Из двух простых высказываний d=,,коля читает книгу р=,,коля пьёт чай составили сложное высказывание ,,коля читает книгу или не пьёт чай выбери верный ответ 1)когда d,тогда обязательно...
Ymnusha
22.10.2021 06:28
Метеорологическая станция ведет наблюдение за температурой воздуха. температура представлена целым числом в диапазоне от -43 до +51 градуса. каждое значение измерений записывается...
гнеуй
22.10.2021 06:28
Найти значение логического выражения (x 11)& (x 10) для числа x=2...
natashalixarev
22.10.2021 06:28
Из двух простых высказываний f=,,люба читает книгу h=,,люба пьёт молоко составили сложное высказывание,,люба читает книгу и пьёт молоко выбери верный ответ 1)нет f и не h 2)не то...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
gd, gm, xc, yc, r, x, y: integer;
begin
clrscr;
repeat
writeln('Vvedite koordinaty levogo kolca, x=[50..300], y=[50..350]:');
readln(xc, yc);
until((xc >= 50) and (xc <= 300)) and ((yc >= 50) and (yc <= 350));
gd := 0;
initgraph(gd, gm, '');
setbkcolor(15);
cleardevice;
r := 50;
setlinestyle(0, 0, 3);
setcolor(9);
circle(xc, yc, r);
setcolor(8);{темно-серый, черный не нарисовать}
circle(xc + 2 * r, yc, r);
setcolor(12);
circle(xc + 4 * r, yc, r);
setcolor(14);
circle(xc + r, yc + r, r);
setcolor(10);
circle(xc + 3 * r, yc + r, r);
readln
end.