В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
152003152003
152003152003
08.06.2023 11:57 •  Информатика

Дан массив а состоящий из элементов n массив b состоящий из элементов m составить программу которая меняет порядок элементов на обратный (для ввода печати использовать функцию )в с++

Ответ:
поварешка1
поварешка1
07.10.2020 05:24
Сначала вводится N(кол-во эл-в в массиве), потом сам массив a.
Потом вводится M и массив b.
Программа выводит перевернутые массивы a и b
Если будут вопросы пиши к комментариям.

#include <bits/stdc++.h>
using namespace std;
int main(){

int N;
cin >> N;
vector<int> a(N);
for (int i = 0; i < N; i++)
    cin >> a[i];
int M;
cin >> M;
vector<int> b(M);
for (int i = 0; i < M; i++)
    cin >> b[i];
reverse(a.begin(), a.end());
reverse(b.begin(), b.end());
for (int i = 0; i < N; i++)
    cout << a[i] << ' ';
    cout << endl;
for (int i = 0; i < M; i++)
    cout << b[i] << ' ';
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?