В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ксеня228
Ксеня228
27.08.2020 19:04 •  Информатика

Написать программу , которая вводит с клавиатуры число от 0 до 999999(использовать переменные типа longint) и выдает на экран дисплея сумму цифр этого числа. напишите в делфи .

Ответ:
pchelenyok
pchelenyok
28.09.2020 10:56
Var
    n: longint;
    i, sum: integer;

begin
    Readln(n);
    Sum := 0;
    
    while n > 0 do
    begin
        Sum := sum + (n mod 10);
        n := n div 10;
    end;
    Writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?