В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kokola500001
kokola500001
18.12.2020 06:20 •  Информатика

Написать программу решения квадратных уравнений. вычисление d оформить процедурой (паскаль).

Ответ:
samo345
samo345
07.10.2020 04:49
Var a,b,c,d:real;
procedure p(a,b,c:real; var d:real);
begin
d:=b*b-4*a*c;
end;
begin
readln(a,b,c);
p(a,b,c,d);
if d<0 then writeln('Корней нет')
else if d=0 then writeln('x = ',-b/(2*a):3:1)
 else writeln('x1 = ',(-b+d)/(2*a):3:1,' x2 = ',(-b-d)/(2*a):3:1);
end.

Пример:
2 3 1
x1 = -0.5 x2 = -1.0
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?