В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ботаник041
ботаник041
05.10.2021 22:07 •  Информатика

По программированию решением 5–7 является программа, написанная на одном из языков программирования. 5–7 необязательно решать для получения полного . ограничение по времени работы программы в 5–7: 1 секунда. решения 5–7 оцениваются, только если они правильный ответ на всех примерах входных и выходных данных, в условии . проверка решений производится сразу же после отправки, по каждой оценивается решение, набравшее наибольшее число . на странице «итог» вы можете видеть окончательный по всем . программа не должна выводить никаких иных сообщений, кроме того, что требуется найти в . во всех целые числа во входных и выходных данных записываются только цифрами (то есть недопустимо использование записи 1000000.0 или 1e6 вместо числа 1000000). каждое число во входных данных записано в отдельной строке. 5. спиннеры спиннер – модная игрушка c подшипником в основании, к которому прикреплены лопасти. афанасий открыл бизнес по производству спиннеров. он выяснил, что за спиннер, у которого n лопастей, покупатели готовы платить a + b × n рублей, но при этом покупатель не станет покупать спиннер, если его цена будет выше c рублей. определите максимальное число лопастей спиннера, который согласится приобрести покупатель. программа получает на вход три числа a, b, c (стоимость основания спиннера, стоимость одной лопасти и максимальная стоимость всего спиннера). все числа – целые положительные, не превосходящие 2×109 , при этом a ≤ c. программа должна вывести одно число – максимальное число лопастей спиннера. пример входных и выходных данных ввод вывод примечание 20 10 55 3 спиннер с 3 лопастями будет стоить 50 рублей, а с 4 лопастями – 60 рублей. максимальная возможная стоимость спиннера – 55 рублей, поэтому максимальное число лопастей равно 3.

Ответ:
ночнойфилин
ночнойфилин
07.10.2020 01:54
Во вложеном файле приведено решение на  языке С++.
А вот на Pascal:

program Znanija;
var a, b, c, n: integer;
begin

read(a);
read(b);
read(c);
n:=(c-a) div b;
writeln();
writeln(n);

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?