В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mashapermyakova
mashapermyakova
25.03.2022 14:00 •  Информатика

Написать программу в паскале. ввести с клавиатуры 6 произвольных чисел. вычислить среднее арифметическое тех чисел, которые делятся на 4 и заканчиваются на 5.( остаток на деление на 10 равен 5).

Ответ:
pridanivdanil
pridanivdanil
07.10.2020 01:02
Var i, x, count: integer;
    sum: real;

begin
    sum := 0;
    count := 0;
    for i := 1 to 6 do
        begin;
        writeln('Введите число');
        readln(x);
        if (x mod 4 = 0) or (x mod 10 = 5) then
            begin;
            sum := sum + x;
            count := count + 1;
            end;
        end;
    writeln(sum/count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?