Войти
Регистрация
Спроси ai-bota
В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Показать больше
Показать меньше
verazotova04
15.11.2021 10:46 •
Информатика
Нужно написать программу для паскаль авс, (тема: циклы с пред-пост-условием)что бы программа выводила на экран знак «*» до тех пор, пока не будет введен с клавиатуры знак «0»
Ответ:
kem8
07.10.2020 00:15
Var a: integer;
begin
//пред условие
read(a);
while a <> 0 do
begin
writeln('*');
read(a);
end;
end.
var a: integer;
begin
//пост условие
repeat
writeln('*');
read(a);
until a=0
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Nastya14231
08.10.2020 17:37
Какое устроество требуется для размножения конспекта в 90 экземпляров? ( )...
turansalehova
08.10.2020 17:37
Написать линейную программу: (a+b)*c=d где a,b вводиться с клавиатуры. c=5 !...
софия682
12.10.2020 10:05
Сколько бит информации содержится в 1 мб ?...
anna0969
01.02.2020 00:22
Водной компании работают программисты, которые всегда говорят правду, и хакеры, которые всегда лгут. при этом от напряженной работы часть сотрудников сошла с ума и придерживается...
aiha4567
05.02.2023 09:25
Мы привыкли к тому, что в позиционных системах счисления «вес» единицы любого разряда, кроме младшего, всегда равен произведению «веса» предыдущего на основание системы...
Шаров2005
28.05.2022 20:24
1. Безье қисығы деген не? . Қисық сызықтарды салудың қандай режимдерiн бi- лесің? . Қисық сызықтармен сызылған суреттердің бағытын ауыстыруға бола ма? Суреттерді қандай...
nastyaborisova13
03.03.2023 05:30
Ученик написал сочинение объемом 32 Кбайт. Каждая страница сочинения состоит из 64 строк по 32 символа в строке. Мощность алфавита - 256. Из скольких страниц состоит сочинение?...
petrokozlo998
14.02.2020 13:06
1)4≥ 16^x+12)2^(х^2 - 9х + 17,5) √2/83) (0,25)^4-х ≤ 16/2^х-2...
ilnasgo54
14.12.2022 21:59
Як ви гадаєте, що є спільного між телеграмою, телефонограмою і факсом?...
катююсик
26.12.2022 22:57
плз соч по познанию мира в верху было написано~определить 4 основных климата на земле~...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
//пред условие
read(a);
while a <> 0 do
begin
writeln('*');
read(a);
end;
end.
var a: integer;
begin
//пост условие
repeat
writeln('*');
read(a);
until a=0
end.